commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <btomas...@neteverything.com>
Subject Re: Moving up to JVM 1.4+
Date Tue, 30 Dec 2003 23:19:07 GMT
I also work with a large company who is back in the 1.3 
days, and they use WAS 4.0.

It seems like two releases of suuport is pretty common 
rule of thumb on this.

So, WAS 6.0 is starting public beta, once released, we are 
two releases from WAS 4.0.

Same with JDK 1.3.  1.5 is on the horizon, so then 1.3 is 
fair game to deprecate at that time (?).

For some reason, big companies like to be one release 
back, but two starts to get them motivated.

On Tue, 30 Dec 2003 17:01:51 -0500
  Vic Cekvenich <cekvenich_vic@basebeans.com> wrote:
>As others said, if this should not stand in a way of 
>progress and competition.
>
>Your clients can still use the current releases of jars 
>that are 1.3, right? They would still be available and 
>source for them would be available.
>One day you can sell them on 1.4 upgrades.
>
>.V
>
>Gary Gregory wrote:
>>Our app server product's requirement is 1.3.1. We cannot 
>>ask our customer to
>>move to 1.4+. :-(
>>
>>Why? I'll try to be brief.
>>
>>(1) WebSphere is important to our customers and our stuff 
>>has to work in WS.
>>The /majority/ of our installed based and prospects are 
>>still on the
>>1.3-based WS.
>>
>>(2) OS upgrades. For new JRE versions, on certain OS's, 
>>that means OS
>>patches. For our OS/400 and S/390 customers this is a BIG 
>>deal.
>>
>>Gary
>>
>>
>>>-----Original Message-----
>>>From: Noel J. Bergman [mailto:noel@devtech.com]
>>>Sent: Tuesday, December 30, 2003 09:07
>>>To: Jakarta Commons Developers List
>>>Subject: Moving up to JVM 1.4+
>>>
>>>
>>>>This has come up in regards to using some of java.nio in 
>>>>Commons/Net
>>>
>>>also.
>>>
>>>>I say we leave the last release as 1.1 compatible and 
>>>>move on to using
>>>>1.4+ for new versions.
>>>
>>>Personally, I use JVM 1.4+, myself.  However, everytime 
>>>we do a survey on
>>>server-user, we get emphatic feedback from our users to 
>>>preserve support
>>>for
>>>JVM 1.3.1.  Before dropping support for pre-1.4 systems, 
>>>perhaps it would
>>>be
>>>a good idea to raise the question on the user list?
>>>
>>>There are also ways to support pre-1.4 while still 
>>>gaining the advantage
>>>of
>>>1.4+ systems when available.
>>>
>>>	--- Noel
>>>
>>>
>>>---------------------------------------------------------------------
>>>To unsubscribe, e-mail: 
>>>commons-dev-unsubscribe@jakarta.apache.org
>>>For additional commands, e-mail: 
>>>commons-dev-help@jakarta.apache.org
>>
>>
>
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: 
>commons-dev-unsubscribe@jakarta.apache.org
>For additional commands, e-mail: 
>commons-dev-help@jakarta.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message