commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Corby Page" <CPa...@duke-energy.com>
Subject Re: [DbUtils]Making the BeanHandler... Even Smarter
Date Tue, 02 Dec 2003 16:02:05 GMT
(Sorry for breaking the threading, I have some primitive limitations on the
corporate mail system)

David writes: "Would changing mapColumnsToProperties() to protected allow
you to fully
implement your request?"

Yes, thank you, I would also request that you make the PROPERTY_NOT_FOUND
field protected as well.

David writes: "Is representing the mapping as an int[] the best
way of doing things?"

Probably, because its the fastest. I think it would cleaner if we returned
a Map that maps column names to property names, but that might be more
overhead than we want to put in this piece.

David writes: "Is there a better name for the method?"

No, I think mapColumnsToProperties() is perfect.

David writes: "The whole point of defining a RowProcessor interface was to
allow people to implement whatever special features they needed without
having to customize our simple default BasicRowProcessor implementation."

I hear you, but when I found myself copying and pasting the entire
BasicRowProcessor class just to override one private method, that seemed
like a bad design smell to me. Mapping columns to properties feels like a
legitimately generalizable concern.

Thanks,
Corby




---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message