commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Libbrecht <p...@activemath.org>
Subject Re: Moving up to JVM 1.4+
Date Tue, 30 Dec 2003 17:44:49 GMT
Our current server (ActiveMath) is blocked entirely by JDK 1.4: it's a 
server with slightly too heavy memory requirements and the result is... 
OutOfMemoryError on most Unix-VMs if in JDK 1.4. (especially true on 
MacOSX, very frequent on Sun and Blackdown's on Linux).
Hence the wish not to depend on this for libraries that we would take.

However, I wouldn't object the build of a jakarta-commons component to 
require JDK 1.4.

Paul



On 30-Dec-03, at 18:06 Uhr, Noel J. Bergman wrote:

>> This has come up in regards to using some of java.nio in Commons/Net 
>> also.
>> I say we leave the last release as 1.1 compatible and move on to using
>> 1.4+ for new versions.
>
> Personally, I use JVM 1.4+, myself.  However, everytime we do a survey 
> on
> server-user, we get emphatic feedback from our users to preserve 
> support for
> JVM 1.3.1.  Before dropping support for pre-1.4 systems, perhaps it 
> would be
> a good idea to raise the question on the user list?
>
> There are also ways to support pre-1.4 while still gaining the 
> advantage of
> 1.4+ systems when available.
>
> 	--- Noel
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-dev-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message