commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From robert burrell donkin <robertburrelldon...@blueyonder.co.uk>
Subject Re: [digester] variable expansion
Date Wed, 03 Dec 2003 23:37:34 GMT
hi ash
On 3 Dec 2003, at 09:59, ASHWIN Suresh wrote:

> Sorry to jump in to this thread this way, and perhaps it is too late 
> now.
> But, have the people here considered using the term "resolve"
> for this concept?
>
> Perhaps the interface could be named Resolver, with the method 
> resolve().
>
> I can think of ${foo} > xyz as resolving the definition rather than 
> simple
> substitution,
> thow at a lower level of abstraction, it is substitution.
>
> If this has been considered and vetoed, please ignore my email.

i'm usually pretty bad on naming at the best of times - and worse when 
i'm tied (too many lists, too little sleep 8-)

but i think that substitution is what the top level interface does 
(rather than resolution).

resolver is also an overused word in xml. we'd probably need to prefix 
it with an adjective -  VariableResolver, say. i think that 
VariableResolver is probably a slightly better name than 
VariableExpander for the interface decoupling the variable 
expansion/resolution implementation  but i think that simon's original 
name is very reasonable. i'd be happy to go with the consensus on this. 
comments anyone?

> One more point:
>
>> The spelling "substituter" feels more natural to me than
>> "substitutor".
>>
>> cf.:
>> to write --> writer
>> to drive --> driver
>> to expand --> expander
>
>
> For Latinate words, the pattern is usually -or.
> Constructor, translator, delegator, etc.
> Whenever, the agent form is formed out of removal of -ion, the 
> preferred
> suffix is -or.
> Thus, the more appropriate form is substitutor.
> Again, perhaps this was already discussed.

you seem to have put a lot more thought into it than i did :)

i intended it as a bit of a play on words - substitutor ~ terminator. 
digester has an 'e' but 'o' is probably better grammar. again, i be 
happy to bow to consensus. views anyone?

- robert


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message