commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From __matthewHawthorne <>
Subject Re: [io] docs and refactorings
Date Sun, 28 Dec 2003 18:42:06 GMT
Jeremias Maerki wrote:
>>Packages and
>>I'd like to merge these into one package which contains all 
>>InputStreams, OutputStreams, Readers and Writers.  Currently, we have 1 
>>Writer, 0 Readers, and the rest are streams.  I just think it makes more 
>>sense to have these classes side by side.  For example -- 
>>ProxyInputStream and ProxyOutputStream, DemuxInputStream and 
>>DemuxOutputStream.  These classes will most like be used together, and 
>>change together, so lets put them together.
>>Here are some ideas for a name:
>>- good, but there may be readers, writers also
> I like this most. I don't think there is a problem if we put Readers and
> Writers in there.

OK, then perhaps io.streams is the best place.  However, I believe that 
Henri preferred leaving the classes split between io.input and 
io.output.  Henri, can you chime in and give us the reason for your 
opinion on this again?

>>This class only has one method, dump(byte[], long, OutputStream, int).
>>I would like to move this method to IOUtils as dumpHex, then deprecate
>>and remove the original class.
> -0. I'm thinking about visibility. I don't like filling up IOUtils with
> too much. People need to find out quickly what capabilities IO has. For
> HexDump (a class I haven't looked at, yet) I can imagine several layout
> modes. The code for that may inflate IOUtils too much for my taste.

I didn't quite understand HexDump.  If you feel that it has room to grow 
and would clutter IOUtils, then let's leave it.

Also, what are the opinions on renaming IOUtils to IoUtils?  I think 
there's a guideline in "Elements of Java Style" that suggests 
capitalizing acronyms in this way.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message