commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Todd V. Jonker" <t...@consciouscode.com>
Subject Re: [lang] StringUtils.subarray v/s subArray
Date Mon, 01 Dec 2003 17:51:03 GMT
I agree with Aswin.  "substring" and "subset" are proper words and
therefore shouldn't have a capital in the middle.  The coined term
"subarray" is a clear sibling with entirely analogous semantics, so it
should be treated as a single word.  The capitalization of "subList"
sounds like it's out of standard.

.T.

On Sun, 30 Nov 2003 13:40:39 -0000, "Stephen Colebourne"
<scolebourne@btopenworld.com> said:
> I changed this based on subList() in the collections API. substring() is
> an
> alternative precedent, so I am open to opinions.
> 
> Stephen
> 
> ----- Original Message -----
> From: "Ash .." <equinus100@hotmail.com>
> > Thanks for integrating the subarray implementation patch.
> >
> > However, I am curious to know why Stephen chose to name the method
> > "subArray", in place of
> > "subarray".
> > In the English language, the prefix "sub" in this sense is joined to the
> > word with the resultant word being a single "token": subunit, subclass,
> > suburbs, subway... substring, subarray,
> > whereby, as per standard Java conventions, the name ought to be "subarray"
> > rather than "subArray".
> > Even names in Standard API reflect this: substring, etc.
> >
> > thanks,
> > Ashwin

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message