commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lee Crawford" <lee.crawf...@stadeon.com>
Subject RE: [io] IOUtils shutdown
Date Mon, 29 Dec 2003 02:38:01 GMT
I also don't like the shutdownXxxx method naming convention. But, I
think that close doesn't convey the 'added' functionality of these
convenience methods. 

How about safeClose(XXX) instead? 

--lee

-----Original Message-----
From: Stephen Colebourne [mailto:scolebourne@btopenworld.com] 
Sent: Sunday, December 28, 2003 8:56 PM
To: Jakarta Commons Developers List
Subject: [io] IOUtils shutdown


The IOUtils shutdownXxx methods seem oddly named to me, especially given
their usefulness.

   IOUtils.close(stream)

would seem much more sensible (and shorter!)

Stephen


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message