commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephen Colebourne" <>
Subject Re: [io] docs and refactorings
Date Sun, 28 Dec 2003 19:34:05 GMT
From: "__matthewHawthorne" <>
> >>Packages and
> >>----------------------------------------------------------------
> OK, then perhaps io.streams is the best place.  However, I believe that
> Henri preferred leaving the classes split between io.input and
> io.output.  Henri, can you chime in and give us the reason for your
> opinion on this again?
I also support input and output (as is), as they just seem like an obvious
classification. Is there any real need for them to be together?
[collections] has suffered by putting things in one place when they should
have been split.

> Also, what are the opinions on renaming IOUtils to IoUtils?  I think
> there's a guideline in "Elements of Java Style" that suggests
> capitalizing acronyms in this way.
I wouldn't change from IOUtils, it just looks right.

Actually, you might want to consider InputUtils and OutputUtils instead.
Again, this seems like the obvious classification.


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message