commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephen Colebourne" <scolebou...@btopenworld.com>
Subject Re: [lang] StringUtils.subarray v/s subArray
Date Mon, 01 Dec 2003 20:36:46 GMT
Sounds like subarray has more backing. Anyone want to jump in and make the
change?
Stephen

----- Original Message -----
From: "Gary Gregory" <ggregory@seagullsw.com>
> Even thought I like naming issues, I've happily staying out of this one...
> but this is a nice point, "sub" is a prefix not a word, therefore subarray
> seems quite appropriate. I agree with Todd: "Capitalization goes between
> words, not inside them."
>
> (I also consider acronyms words for this purpose to avoid crazy names like
> IBMXMLDOMThing in favor of IbmXmlDomThing)
>
> Gary
>
> > -----Original Message-----
> > From: Todd V. Jonker [mailto:todd@consciouscode.com]
> > Sent: Monday, December 01, 2003 09:54
> > To: Jakarta Commons Developers List
> > Subject: Re: [lang] StringUtils.subarray v/s subArray
> >
> >
> > On Sun, 30 Nov 2003 12:33:40 -0800, "__matthewHawthorne"
> > <matth@phreaker.net> said:
> > > It seems to depend on whether we see the word "array" as a proper
noun.
> > >
> > > java.lang.String has both substring and subSequence.  There seem to be
> > > inconsistencies everywhere.
> > >
> > > I vote for subArray, since I would define a classname as being a
proper
> > > noun.
> >
> > But "sub" isn't a word of any kind in this context, it's a prefix.
> > Capitalization goes between words, not inside them.
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
> > For additional commands, e-mail: commons-dev-help@jakarta.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message