commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike Stanley" <mstan...@cauldronsolutions.com>
Subject Betwixt troubles...
Date Fri, 07 Nov 2003 18:26:16 GMT
Hey everyone,

I'm running into an issue with some Betwixt code.  I'm trying to Write/Read
a bean associated with .betwixt file.

I can't seem to get attributes to be set when reading in the xml.  writing
works fine.  I've tried several ways (including defaulting to primitiveTypes
and specificing an updater method).  Here is the content of the file:

<?xml version="1.0" encoding="UTF-8"?>
<info primitiveTypes="attribute">
    <element name="rcss">
        <attribute property="type"/>
        <element name="requests">
            <element name="isValid">
                    <element name="agent-id">
                        <attribute name="value" property="agentId"/>
                    </element>
                    <!-- <element name="agent-id" property="agentId"
updater="setAgentId"/> -->
            </element>
        </element>
    </element>
</info>

----
Results form a write:

<?xml version='1.0' ?>
<rcss type="request" src="167.154.203.22" requestor="install_app">
    <requests>
        <isValid cert="Z0123456789">
            <agent-id value="01"/>
        </isValid>
</requests>
</rcss>

---
Results from read:

<?xml version='1.0' ?>
<rcss type="request" src="167.154.203.22" requestor="install_app">
    <requests>
        <isValid>
            <agent-id/>
        </isValid>
</requests>
</rcss>

---
What is going wrong?  What can I do to fix this problem?  modifying the
format of the XML is not an option.  Also note - using the Commented out
element in the betwixt file instead of specifically specifying the
attribute, results in <agent-id>01</agent-id> which isn't correct either.

Thanks for your help.
- Mike

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message