commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shah, Mehul - Contractor" <mehul.s...@xo.com>
Subject RE: File Upload does not work....
Date Wed, 26 Nov 2003 17:35:55 GMT

All,

I fixed the problem. I had commons-fileupload.jar in
%JAVA_HOME%\jre\lib\ext and also in my web-inf/lib directories. This
caused the problem. I don't understand why would it cause a problem but
for now it is working.

I am sorry for the inconvenience and thanks for your help.

-Mehul Shah

-----Original Message-----
From: Craig R. McClanahan [mailto:craigmcc@apache.org] 
Sent: Tuesday, November 25, 2003 9:55 PM
To: Jakarta Commons Developers List; Shah, Mehul - Contractor
Cc: commons-dev@jakarta.apache.org; rpieroni@dexem.com;
jan.vervecken@pandora.be
Subject: Re: File Upload does not work....

Quoting "Shah, Mehul - Contractor" <mehul.shah@xo.com>:

> Hello,
> 
>  
> 
> I am using Tomcat 4.1 and Commons-FileUpload api. I cant get it
working.
> I get the following error:
> 

One thing to ensure is that you're not trying to include servlet.jar
inside your
webapp (since it's built in to Tomcat already).  Including servlet.jar
is
pretty much guaranteed to cause you very wierd errors, and this could
certainly
be one of them.

On the other hand, it is important to include commons-fileupload.jar and
any
JARs it depends on (see the docs) in your webapp's WEB-INF/lib
directory.

Craig


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message