commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ash .." <>
Subject Re: [lang] StringUtils.subarray v/s subArray
Date Sun, 30 Nov 2003 19:24:31 GMT
I see two factors here, one, instances in the the standard Java API, two, 
mapping of natural language to Java convention.

In the first case, we can say there is some incoherence, since you find both 
"substring" and "subList". Thus, the second one, is perhaps a better guide 
to making a decision here. Thus, I would say, one might go with how the 
names translate into Java convention (= subarray.)
It would be good to have others' comments on this too.

----- Original Message -----

I changed this based on subList() in the collections API. substring() is an
alternative precedent, so I am open to opinions.


----- Original Message -----
From: "Ash .." <>
>Thanks for integrating the subarray implementation patch.
>However, I am curious to know why Stephen chose to name the method
>"subArray", in place of
>In the English language, the prefix "sub" in this sense is joined to the
>word with the resultant word being a single "token": subunit, subclass,
>suburbs, subway... substring, subarray,
>whereby, as per standard Java conventions, the name ought to be "subarray"
>rather than "subArray".
>Even names in Standard API reflect this: substring, etc.

Hotmail messages direct to your mobile phone

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message