commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ash .." <>
Subject [lang] StringUtils.subarray v/s subArray
Date Sun, 30 Nov 2003 10:15:47 GMT
Thanks for integrating the subarray implementation patch.

However, I am curious to know why Stephen chose to name the method 
"subArray", in place of
In the English language, the prefix "sub" in this sense is joined to the 
word with the resultant word being a single "token": subunit, subclass, 
suburbs, subway... substring, subarray,
whereby, as per standard Java conventions, the name ought to be "subarray" 
rather than "subArray".
Even names in Standard API reflect this: substring, etc.


Tired of 56k? Get a FREE BT Broadband connection

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message