commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ash .." <equinus...@hotmail.com>
Subject RE: [lang] StringUtils.subarray v/s subArray
Date Sun, 30 Nov 2003 21:05:54 GMT

>
>It seems to depend on whether we see the word "array" as a proper noun.


Could you please elaborate what you meant by that.

In my understanding, class names rather represent common nouns, and you can 
say, specific instances of the class represent proper nouns:

Person john = new Person();

Or, am I missing something here?

Talking about String.subSequence, if I am right, it was so named because 
there exists a word called "subsequence" in English, which has no direct 
bearing with "sub + sequence", thus the emphasis:
"sub-sequence". Another example would be re-store (= store again.)

Ash




>-----Original Message-----
>From: __matthewHawthorne [mailto:matth@phreaker.net]
>Sent: Sunday, November 30, 2003 20:34
>To: Jakarta Commons Developers List
>Subject: Re: [lang] StringUtils.subarray v/s subArray
>
>
>It seems to depend on whether we see the word "array" as a proper noun.
>
>java.lang.String has both substring and subSequence.  There seem to be 
>inconsistencies everywhere.
>
>I vote for subArray, since I would define a classname as being a proper 
>noun.
>
>
>
>
>Stephen Colebourne wrote:
> > I changed this based on subList() in the collections API. substring() is 
>an
> > alternative precedent, so I am open to opinions.
> > > Stephen
> > > ----- Original Message -----
> > From: "Ash .." <equinus100@hotmail.com>
> > >>Thanks for integrating the subarray implementation patch.
> >>
> >>However, I am curious to know why Stephen chose to name the method
> >>"subArray", in place of
> >>"subarray".
> >>In the English language, the prefix "sub" in this sense is joined to the
> >>word with the resultant word being a single "token": subunit, subclass,
> >>suburbs, subway... substring, subarray,
> >>whereby, as per standard Java conventions, the name ought to be 
>"subarray"
> >>rather than "subArray".
> >>Even names in Standard API reflect this: substring, etc.
> >>
> >>thanks,
> >>Ashwin

_________________________________________________________________
Set yourself up for fun at home!  Get tips on home entertainment equipment, 
video game reviews, and more here.   
http://special.msn.com/home/homeent.armx


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message