commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Al Chou <>
Subject Re: [math] Proposal for Package restructuring and Class renaming
Date Mon, 10 Nov 2003 03:51:05 GMT
--- "Mark R. Diggory" <> wrote:
> Al Chou wrote:
> > 
> > OK, I see.  The one thing I notice is that the names are getting awfully
> long,
> > especially for the non-default case.  I guess that's a price we pay for
> having
> > descriptive (no play on words intended) names like
> DescriptiveStatistics....
> Maybe the Implementations could be abbreviated somewhat
> o.a.c.math.stat.DescriptiveStatistics
> o.a.c.math.stat.StorelessDscrStatsImpl
> o.a.c.math.stat.DscrStatsImpl
> We could also consider pushing the actual implementation off into its 
> own packages
> o.a.c.math.stat.impl.StorelessDscrStatsImpl
> o.a.c.math.stat.impl.DscrStatsImpl
> This would even push all the univariate stat providers off into this 
> hierarchy as well
> o.a.c.math.stat.impl.univar.StorelessUnivariateStatistic
> o.a.c.math.stat.impl.univar.UnivariateStatistic

Too much renaming and reorganization.  I didn't mean to complain too loudly,
and if the result is to use abbreviations, I retract my comments.  I probably
should have given more than half a second's thought to what alternative names
might be shorter, but in the absence of well-thought-out shorter names, I much
prefer the current proposal of DescriptiveStatistics.  Never use abbreviations
unless everyone already knows them (e.g., sin for sine), I say.


Do you Yahoo!?
Protect your identity with Yahoo! Mail AddressGuard

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message