commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin van den Bemt <mll...@mvdb.net>
Subject RE: Betwixt troubles...
Date Sun, 09 Nov 2003 17:14:11 GMT
Can you supply us with a tescase that shows us the bahaviour (esp that
you believe it is a bug), since there is too little info in the mail to
test this (we needs the beans / bean. One thing I know is that eg
Bean.betwixt files only supplies beaninfo for Bean.java and not for any
classes embedded in Bean.java. 

Mvgr,
Martin

On Fri, 2003-11-07 at 19:51, Mike Stanley wrote:
> Please note: I sent this to the developers list and not the users list,
> because I believe it to be a bug, and if confirmed - I may patch it.
> 
> - Mike
> 
> > -----Original Message-----
> > From: Mike Stanley [mailto:mstanley@cauldronsolutions.com]
> > Sent: Friday, November 07, 2003 1:26 PM
> > To: Jakarta Commons Dev
> > Subject: Betwixt troubles...
> >
> >
> > Hey everyone,
> >
> > I'm running into an issue with some Betwixt code.  I'm trying to
> > Write/Read
> > a bean associated with .betwixt file.
> >
> > I can't seem to get attributes to be set when reading in the xml.  writing
> > works fine.  I've tried several ways (including defaulting to
> > primitiveTypes
> > and specificing an updater method).  Here is the content of the file:
> >
> > <?xml version="1.0" encoding="UTF-8"?>
> > <info primitiveTypes="attribute">
> >     <element name="rcss">
> >         <attribute property="type"/>
> >         <element name="requests">
> >             <element name="isValid">
> >                     <element name="agent-id">
> >                         <attribute name="value" property="agentId"/>
> >                     </element>
> >                     <!-- <element name="agent-id" property="agentId"
> > updater="setAgentId"/> -->
> >             </element>
> >         </element>
> >     </element>
> > </info>
> >
> > ----
> > Results form a write:
> >
> > <?xml version='1.0' ?>
> > <rcss type="request" src="167.154.203.22" requestor="install_app">
> >     <requests>
> >         <isValid cert="Z0123456789">
> >             <agent-id value="01"/>
> >         </isValid>
> > </requests>
> > </rcss>
> >
> > ---
> > Results from read:
> >
> > <?xml version='1.0' ?>
> > <rcss type="request" src="167.154.203.22" requestor="install_app">
> >     <requests>
> >         <isValid>
> >             <agent-id/>
> >         </isValid>
> > </requests>
> > </rcss>
> >
> > ---
> > What is going wrong?  What can I do to fix this problem?  modifying the
> > format of the XML is not an option.  Also note - using the Commented out
> > element in the betwixt file instead of specifically specifying the
> > attribute, results in <agent-id>01</agent-id> which isn't correct either.
> >
> > Thanks for your help.
> > - Mike
> >
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-dev-help@jakarta.apache.org
-- 
Martin van den Bemt <mllist@mvdb.net>
mvdb.com


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message