commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hope, Matthew" <>
Subject RE: [primitives] Package layout strategy
Date Wed, 15 Oct 2003 09:26:31 GMT
I had forgotten this - I agree something like pint, pboolean etc is
cumbersome and counter-intuitive and would negate a significant reason for
my suggestion so prob not worth it.

-----Original Message-----
From: Brent Worden [] 
Sent: 14 October 2003 00:55
To: Jakarta Commons Developers List
Subject: RE: [primitives] Package layout strategy
To my knowledge, the type based packaging as presented is not possible.
boolean, byte, short, et al are Java keywords and can not be used as parts
of a package name.  So, if a type based approach is to be employed,
convoluted names for primitive types would need to be used instead of their
conventional names.  With that, I would say, the collection based approach
is clearly the better alternative.

The information transmitted herewith is sensitive information intended only
for use by the individual or entity to which it is addressed. If the reader
of this message is not the intended recipient, you are hereby notified that
any review, retransmission, dissemination, distribution, copying or other
use of, or taking of any action in reliance upon this information is
strictly prohibited. If you have received this communication in error,
please contact the sender and delete the material from your computer.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message