commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Harish Krishnaswamy <>
Subject Re: [HiveMind] naming update
Date Thu, 18 Sep 2003 15:43:47 GMT
I agree, I wasn't very inclined towards that either, just wanted to see 
what others thought. But implementation is not very intuitive at least 
in the following case, I think...

<implementation ...>
    <interceptor .../>

Contribution seems appropriate. So how about <service-contribution> and 


Howard M. Lewis Ship wrote:

>>Option D:
>><service-point id="...">
>><service-definition point-id="...">
>><configuration-point id="...">
>><configuration-definition point-id="...">    // not very sure 
>>about this 
>That seems off to me; <service-definition> is close, I think, but not quite accurate
(that's why I
>like <implementation>, which is very accurate).
><configuration-definition> is way off, since it doesn't define the configuration,
it provides a part
>of the configuration; that's why I keep coming back to "contribution".
>To unsubscribe, e-mail:
>For additional commands, e-mail:

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message