commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Harish Krishnaswamy <hkrishnasw...@comcast.net>
Subject Re: [HiveMind] naming update
Date Thu, 18 Sep 2003 13:35:55 GMT
And may be even change

<extend-service service-id=> --> <service for-point-id=>

I think the same pattern will be helpful learning it easier and 
remembering it better.

-Harish

Harish Krishnaswamy wrote:

> Absolutely with Christian. For some reason I am not very comfortable 
> with verbs in the element names!
>
> -Harish
>
> Christian Essl wrote:
>
>> On Thu, 18 Sep 2003 07:38:41 -0400, Howard M. Lewis Ship 
>> <hlship@comcast.net> wrote:
>>
>>> Harish's suggestion:
>>>
>>> <service id=> --> <service-point id=>
>>> <extend-service service-id=> --> <service service-id=>
>>> <extension-point id=> --> <configuration-point id=>
>>> <extension point-id=> --> <configuration point-id=>
>>>
>>
>>> Last point was the excessive simularity of <configuration-point 
>>> id="..."> and <configuration
>>> point-id="...">.
>>>
>>> Perhaps that should be <configuration for-point-id="..."> to help 
>>> distinguish the two visually?
>>>
>>
>> I think this is all right. So I would say
>>
>> <service id=> --> <service-point id=>
>> <extend-service service-id=> --> <service service-id=>
>> <extension-point id=> --> <configuration-point id=>
>> <extension point-id=> --> <configuration for-point-id=> //only change

>> to Harish's suggestion
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
>> For additional commands, e-mail: commons-dev-help@jakarta.apache.org
>>
>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-dev-help@jakarta.apache.org
>
>


Mime
View raw message