commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Gregory <ggreg...@seagullsw.com>
Subject RE: [lang] StringUtils.differenceAt()
Date Thu, 21 Aug 2003 15:10:20 GMT
Any opinions on changing differenceAt() to indexOfDifference() ?

Gary

> -----Original Message-----
> From: Gary Gregory [mailto:ggregory@seagullsw.com]
> Sent: Wednesday, August 20, 2003 23:01
> To: 'Jakarta Commons Developers List'
> Subject: [lang] StringUtils.differenceAt()
> 
> Hello,
> 
> We have new 2.0 method called differenceAt() but I believe it is not named
> correctly. Methods with "At" usually receive an index argument, like
> String.charAt(). This method /returns/ an index.
> 
> I think indexOfDifference() would be better and in the same vein as
> String.indexOf().
> 
> Gary
> (fyi, off to bed if there is any voting goin' on)

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message