commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephen Colebourne" <scolebou...@btopenworld.com>
Subject [lang] StringUtils overlay/concatenate/getNested
Date Fri, 01 Aug 2003 00:11:45 GMT
One final pass through StringUtils suggests these method names as dubious

- overlayString - shouldn't have 'String' in name. Better named as 'replace'

- concatenate - does the name as join(array, null) so should be called
join(array)

- getNestedString - poor name, again with String in it.


Any views on changing these names (by deprecation of course)

Stephen


Mime
View raw message