commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Janek Bogucki <>
Subject Re: [lang] StringUtils.sliceFirstRemainder behavior
Date Fri, 25 Jul 2003 11:06:03 GMT
On Friday 25 Jul 2003 12:58 am, Stephen Colebourne wrote:
> This is checked in now.
> Actually today I came across the JSTL method names substringAfter() and
> substringBefore(). Maybe these are better names? Of course you'd need
> substringAfterLast() and substringBeforeLast(), but maybe its more
> expressive than slice. Not sure.
> Stephen

Writing as someone with little experience of Perl (which I think is where 
these method names came from) these names make more sense to me than the 
slice versions.

To me the names you propose are self-evident while the slice versions would 
require me to look at the documentation or unit tests.

My 2 cents.


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message