commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brent Worden" <>
Subject RE: [math] Static Utils and Methods (was: Re: [math] proposed ordering for task list, scope of initial release)
Date Wed, 11 Jun 2003 06:01:11 GMT
> > Again, I can see someone wanting these functions if one wants to be
> > absolutely sure that they are complying with strict conceptual
> > definitions in a very large system.  I don't personally have a need for
> > isPositive, but that isn't to say that Al hasn't found a good reason to
> > use them in the past.
> >
> > Al?  what was the motivation here?
> Wasn't my idea in the first place, I think it was Brent's.

Yes, it was my idea and considering all the flak it has taken, it's
apparently a poor one.  My intent was to provide a means to make boolean
expression less symbolic and more verbose to the end of making them more
humanly readable.  If people don't see the need for it, so be it.  Let's
move on.

On the discussion of MathUtils, StatUtils and the placement of the
average(double, double) method, if the method name was changed to midpoint,
would people prefer it be place in MathUtils, StatUtils, or up my keester.
Please, limit your replies to two emails.


Brent Worden

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message