commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Graham" <>
Subject Re: [Clazz] names of classes
Date Tue, 17 Jun 2003 21:07:45 GMT
>some nitpicking from me (currently trying to write a user guide for me):
>why is
>     ReflectedPropertyIntrospector
>not called
>     ReflectionPropertyInspector?
>Would be a little bit clearer from my point of view, that objects of this
>class are actively
>doing something.

Introspection is an activity and the word most commonly associated with 
discovering a bean's capabilities.

>I do not like the names of ~Support classes. ~Support or ~Helper indicate
>(for me)
>that these are Helper classes with (often static) utility functions. In the
>Java API I think
>I have found the usage of Abstract~ or Base~ much more often for classes

You've missed an important difference between Helper classes and 
Base/Abstract classes.  Helper classes allow composition/reuse outside of a 
class hierarchy.  Abstract class' methods can only be used by subclasses.


>the ~Support classes in Clazz. E.g.
>    ReflectedPropertyIntrospectorSupport
>might be called
>    AbstractReflectedPropertyIntrospector or
>and to keep it consistent with my previous remark, it should be called:
>    AbstractReflectionPropertyIntrospector or
>I would easily agree that these are minor changes, but since I have such a
>time understanding the framework, I just write down every single issue I
>PS: more to come
>To unsubscribe, e-mail:
>For additional commands, e-mail:

The new MSN 8: smart spam protection and 2 months FREE*

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message