commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Phil Steitz <stei...@yahoo.com>
Subject Re: [math] Refactored UnivariateImpl
Date Wed, 18 Jun 2003 01:00:58 GMT

--- "Mark R. Diggory" <mdiggory@latte.harvard.edu> wrote:
> Hi all,
> 
> As this is now a sensitive subject, I'm not going to commit this until I 
> receive +/- input from the group. Please review the following 
> UnivariateImpl and submit your opinion, This version of UnivariateImpl 
> no longer extends AbstractStoredUnivariate to accomplish delegation, but 
> does delegate methods to an implementation of the static statistical 
> functions in StatUtils, it no longer directly instantiates runtime 
> exceptions.
> 
> -Mark
> 
This is definitely making progress.  I like the structure.  There are a couple
of things that should probably be improved, however:

1. Some relatively trivial stylistic cleanup -- eliminate unecessary "super()"
calls in the constructors and use standard Java naming conventions for
variables (i.e. lose the _'s).  Also there is one remaining reference to
AbstractStoreUnivariate in comments.

2. I am worried about the powers, product and sumsq computations blowing up
prematurely (i.e. before the stats they are used in become NaN) in the infinite
window case, or having bad numerical stability.  We should probably research
better ways to compute these.  If this is too hard to do before initial
release, we might want to consider dropping the higher order moments and
geometric mean from UnivariateImpl.

Phil

__________________________________
Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!
http://sbc.yahoo.com

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message