commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Phil Steitz <stei...@yahoo.com>
Subject Re: [math] Proposed package structure
Date Sun, 15 Jun 2003 21:29:30 GMT

--- "Mark R. Diggory" <mdiggory@latte.harvard.edu> wrote:
> Phil Steitz wrote:
> > I would be open to merging special with analysis, or making it a 
> > subpackage.
> 
> I agree on the package structure, I'm a little hesitant to suggest 
> placing special and analysis together right now until its clearer what 
> the "scope" of each package would encompass.

Special includes numerical approximations to certain useful real-valued
functions used to help numerically approximate distributions in the stat
package.  Both these, rootfinding and interpolation naturally belong to
analysis.
> 
> Wolfram categorizes these as
> 
> Calculus and Analysis > Special Functions > Gamma Functions
> 
> and
> 
> Applied Mathematics > Numerical Methods
> 
> so it may be good to retain separate categorization to describe the 
> scope of each package clearly. Keeping them separate means there room 
> for the implementations within those "scopes" to grow in the future 
> without any "major" refactoring or restructuring of the packages when 
> they get to big. What do you think?
> 
> Also, I now think theres allot more consideration we could put into the 
> package structure that relates back to the scope and definition of the 
> implementations that are present there. It may be wise to review the 
> categorical structure of sites like wolframs and explore similar types 
> of organization as templates for package structuring.
> 
I think it is best to think about how users, both mathematical and
non-mathematical, will be able to find things. The proposed structure is a
decent compromise between standard mathematical classification (which would
replace "linear" with "algebra", for example) and what nonmathematical users
might expect.  I think it is workable.

> -Mark
> 
> > I would also like to change the name of "Freq" to "Frequency".  It 
> > bothers me every time I look at this name, which is a throwback to SAS. 
> >  I should have changed it before submitting the class, but I was too 
> > lazy to change my own code that depends on it. The name should be 
> > changed to be a full word.
> > 
> 
> > 
> 
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-dev-help@jakarta.apache.org
> 


__________________________________
Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!
http://sbc.yahoo.com

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message