commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim O'Brien <>
Subject Re: [math] Priorities, help needed
Date Wed, 21 May 2003 15:43:07 GMT
Take a look at, 
I've added all the tasks described as "Unclassified priority" please 
submit any patches or commit changes to this document to try to coordinate 

Yoav's post about Geometric Mean hints at a Univariate model which would 
use delegation,  but I agree with Phil that for now we should just add 
another function to StoredUnivariate that calculates the geometric mean.  

Further down the road, StoredUnivariate / Univariate could interact with a
registry of Strategy objects which could provide different statistical
measures for a given population.  This registry would be populated with a
set of default Strategy implementations like Mean, GeometricMean,
Kurtosis.  This implementation would be extremely heavy in terms of object
instantiation, but I think it could be completed in an efficient manner.  
It would allow people to easily extend the available Univariate measures
and it might make more sense once we start to add more measures.  BUT, for
right now, this seems to shout "over-engineering", let's just add another
function to StoredUnivariate - being pragmatic.

On Wed, 21 May 2003, Phil Steitz wrote:

> Shapira, Yoav wrote:
> > Howdy,
> > 
> > 
> >>The proposal presents the following initial scope:
> >>
> >>    * Simple univariate statistics (mean, standard deviation, n,
> >>      confidence intervals)
> > 
> > 
> > Does this include just arithmetic means?  We have uses for both and
> > would like both.  This would imply org.apache.commons.math.Mean is an
> > interface / abstract / base class, with at least two implementations.
> > 
> The initial intention was just arithmetic means; but the whole point of 
> this project is to provide utilities that respond to practical needs of 
> applications.  Personally, I would support adding this stuff, even for 
> the initial release (especially if somebody else is willing to code it 
> :-).  I would probably prefer, however, to just add methods to 
> Univariate (and maybe change the name of the mean property to 
> arithmeticMean) rather than defining a Mean interface.  This is because 
> to me, these are actually different statistics.
> > See here for more:
> >
> > 
> > Also, there are other means out there, such as Mathematica's arithmetic
> > geometric mean (AGM) function, outlined here:
> >
> > 2/0001/
> > 
> > I don't mean to add work: these may not be important to anyone else, and
> > they may not be a release-1.0 feature.  But I did want to put them out
> > there, get them on the radar screen.
> > 
> At this point, I think it is most important that we get the real needs 
> of applications captured.  Thanks for the feedback.
> Phil
> > Yoav Shapira
> > 
> > 
> > 
> > This e-mail, including any attachments, is a confidential business communication,
and may contain information that is confidential, proprietary and/or privileged.  This e-mail
is intended only for the individual(s) to whom it is addressed, and may not be saved, copied,
printed, disclosed or used by anyone else.  If you are not the(an) intended recipient, please
immediately delete this e-mail from your computer system and notify the sender.  Thank you.
> > 
> > 
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail:
> > For additional commands, e-mail:
> > 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail:
> For additional commands, e-mail:

Tim O'Brien
Evanston, IL
(847) 863-7045

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message