commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Gregory <ggreg...@seagullsw.com>
Subject RE: [collections] Version 2.2 or 3.0 and removing classes
Date Sat, 10 May 2003 17:51:42 GMT
No objections from me but a suggestion to possibly make it easier for folks
to keep up the new version: should a "collections-deprecated.jar" be
delivered? This might be too much of a pain but it could ease the migration
path for some. 'twas just a thought.

Gary

-----Original Message-----
From: Stephen Colebourne [mailto:scolebourne@btopenworld.com] 
Sent: Saturday, May 10, 2003 5:43 AM
To: Jakarta Commons Developers List
Subject: [collections] Version 2.2 or 3.0 and removing classes

Is the next [collections] release to be 2.2 or 3.0?

If it is 3.0 (as seems to be likely if we are including the primitives
code),  then can I remove the deprecated classes? This would seem
appropriate as they have been deprectated in a release (2.0/2.1) and so
should get removed in the next major version number. This mostly affects
Iterators and Comparators that were moved into the subpackage.

Any objections?

Stephen


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message