commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Corley" <Jason.Cor...@borland.com>
Subject daemon and tomcat
Date Mon, 10 Mar 2003 15:09:13 GMT

I'm not sure whether this is appropriate for tomcat-dev or commons-dev, so I'll post
here first and if it's the wrong forum I'll repost on tomcat-dev.

I'm trying to run tomcat (4.1.18 to be specific) on Linux using the jsvc executable
from jakarta-commons-sandbox/daemon.  Right now I'm having two issues with it's use.
The first is that it doesn't appear to process arguments in the fashion that is
documented.  If run:

    dist/jsvc --help

I get:

    jsvc [-options] class [args...]

however if I run:

    dist/jsvc \
    -user tomcat4 \
    -home /usr/java/j2sdk1.4.1_01 \
    -Dcatalina.home=/var/tomcat4 \
    -Djava.io.tmpdir=/var/tomcat4/temp \
    -cp /usr/java/j2sdk1.4.1_01/lib/tools.jar:dist/commons-daemon.jar:\
/var/tomcat4/bin/bootstrap.jar \
    -debug \
    -verbose \
    org.apache.catalina.startup.BootstrapService stop

it functions exactly the same as if I run jsvc with
org.apache.catalina.startup.BootstrapService start, i.e. it starts tomcat.  So the
argument to the class seems to not be parsed.

Also, when starting tomcat the shutdown port defined in my server.xml (typically
port 8005) does not get allocated at all, so the standard shutdown mechanism does
not work either.

At this point I'm not sure if I've done something wrong or if this functionality has
yet to be implemented.  Any help would be appreciated.

Thanks,
Jason

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message