commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Gregory <ggreg...@seagullsw.com>
Subject RE: [functor] some thoughts
Date Fri, 28 Mar 2003 18:03:51 GMT
<Arnd>In general I do not like abbreviated words as identifier names.  My
reasoning is that it obfuscates the programmers intention and may
imply futile documentation.  I don't think that "eval()" obfuscates
"evaluate()", but this is obviously just my opinion since "eval()"
does appear awkward to you as a replacement for "evaluate()".</Arnd>

The name "evaluate()" makes sense to me. I think names are very important
and while abbrevs tend to produce more compact code (an arguable benefit),
the cost is maintainability: understanding of produced code for years to
come by others.
 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message