commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Downey" <steve.dow...@geowealth.com>
Subject Re: [lang] Adding Purple to StringUtils
Date Thu, 06 Mar 2003 02:06:28 GMT
From: "Steven Caswell" <steven@caswell.name>
To: "'Jakarta Commons Developers List'" <commons-dev@jakarta.apache.org>;
<alex@jguru.com>
Sent: Wednesday, March 05, 2003 4:54 PM
Subject: RE: [lang] Adding Purple to StringUtils


> I mostly agree with Henri's comments. Just a couple of additional comments
> thrown in...
>
>

<snip/>

> > > * toUnderscore
> > >
> > > Converts camelCaseVersusC to camel_case_versus_c
> > >
> > > I'd love to get some ideas on a better name for this.
> > Also, it'd be
> > > nice to have a full, symmetrical set of camelCase vs.
> > under_score vs.
> > > CONSTANT_NAMING vs. "separate words" naming style converters.
> >
> > Hmm. Probably a bit specific for StringUtils. Do people often
> > need this?
>
> +1 to Henri's comment. Seems beyond StringUtils scope.
>

Well, if you do any kind of code generation, you do this kind of thing all
the time. SQL developers seem to avoid CamelCase, relying on underscores
instead. CONSTANT_NAMING seems to be endemic in SQL, in particular. It's at
least as useful as Character.isJavaIdentifierStart() and
Character.isJavaIdentifierPart().


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message