commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steven Caswell" <ste...@caswell.name>
Subject RE: [lang] TrimToNull et al
Date Mon, 24 Mar 2003 01:10:22 GMT
+1 to deprecation because I don't think we should have two operations with
the same functionality. Too confusing. The API is big enough without
unneeded fluff.


Steven Caswell
steven@caswell.name
a.k.a Mungo Knotwise of Michel Delving
"One ring to rule them all, one ring to find them..."


> -----Original Message-----
> From: Stephen Colebourne [mailto:scolebourne@btopenworld.com] 
> Sent: Sunday, March 23, 2003 7:55 PM
> To: Jakarta Commons Developers List
> Subject: [lang] TrimToNull et al
> 
> 
> I have added trimToNull() and trimToEmpty() to StringUtils 
> based on previous discussions.
> 
> trimToEmpty() actually does the same as clean(), but is IMHO 
> a clearer name. Do we want to leave both in, or deprecate clean()?
> 
> Stephen
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-dev-help@jakarta.apache.org
> 
> 



---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message