commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeffrey Dever <>
Subject Re: [codec] RE:
Date Tue, 04 Feb 2003 20:40:40 GMT
Fair enough.  I guess the normal case would be just 
encode/decode(byte[]) without 76 character chunks, which is what 
HttpClient would be using anyway.  

So I take back any preference to method signature, except that the 
"normal" or "default" case be not chunked.  If xml-rpc is going to be 
using the chunked form, then their prefrence should be given high weight.


Henri Yandell wrote:

>I agree with you up until the last point.
>Rather than an obscure and irritating boolean argument on the end, just
>offer a different name.
>public static byte[] decode(byte[] data);
>public static byte[] decodeChunked(byte[] data);
>[bear in mind decodeChunked may be a bad name. I'm just copying :) ]

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message