commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ryan Hoegg <>
Subject Re: [codec] RE:
Date Tue, 04 Feb 2003 20:39:52 GMT
If this is the direction in which we are headed, I would nominate 
Henri's initial idea.  Bear in mind we are not talking about 1.1 here, 
but 2.0 (i.e. future).

For 1.1, my vote (as a committer in XML-RPC) is for Jeffrey's solution, 
with the default being opur consensus on the reading of the relevant RFCs.

For 2.0, I think the idea of a Base64 interface with different 
implementations sounds cleaner than either idea.  Reason being, the user 
of decodeChunked propbably wants to be using encodeChunked as well.

Ryan Hoegg
ISIS Networks

Henri Yandell wrote:

>I agree with you up until the last point.
>Rather than an obscure and irritating boolean argument on the end, just
>offer a different name.
>public static byte[] decode(byte[] data);
>public static byte[] decodeChunked(byte[] data);
>[bear in mind decodeChunked may be a bad name. I'm just copying :) ]
>On Tue, 4 Feb 2003, Jeffrey Dever wrote:
>>There does not seem to be much choice other than overloading the method
>>public static byte[] decode(byte[] data);
>>public static byte[] decode(byte[] data, boolean chunk);

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message