commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From tobr...@transolutions.net (O'brien, Tim)
Subject RE: [codec] RE: Base64.java
Date Tue, 04 Feb 2003 20:50:35 GMT
One would have an encodeChunked, but there would be no need for a
decodeChunked.  Whitespace is discarded in base64 data regardless of the
original encoding scheme.

For 1.1, it looks like a consensus is developing for a Base64 with two
functions, one chunked and one not chunked.  The discussions for 2.0 are
open.  Let me add another possibility. 

Base64 is well understood just as a general encoding scheme outside of RFC
2045 MIME.   RFC 2045 MIME adds a further requirement that the content be
put into 76 character chunks.  Past 1.1 we could also talk about Base64.java
providing the core "base64" encoding, and MIMEBase64.java extending Base64
and adding "pre" and "post" processing to the algorithm.

--------
Tim O'Brien 

> -----Original Message-----
> From: Ryan Hoegg [mailto:rhoegg@isisnetworks.net] 
> Sent: Tuesday, February 04, 2003 2:40 PM
> To: Jakarta Commons Developers List
> Cc: O'brien, Tim; 'Martin Redington'
> Subject: Re: [codec] RE: Base64.java
> 
> 
> If this is the direction in which we are headed, I would nominate 
> Henri's initial idea.  Bear in mind we are not talking about 
> 1.1 here, 
> but 2.0 (i.e. future).
> 
> For 1.1, my vote (as a committer in XML-RPC) is for Jeffrey's 
> solution, 
> with the default being opur consensus on the reading of the 
> relevant RFCs.
> 
> For 2.0, I think the idea of a Base64 interface with different 
> implementations sounds cleaner than either idea.  Reason 
> being, the user 
> of decodeChunked propbably wants to be using encodeChunked as well.
> 
> --
> Ryan Hoegg
> ISIS Networks
> http://www.isisnetworks.net
> 
> Henri Yandell wrote:
> 
> >I agree with you up until the last point.
> >
> >Rather than an obscure and irritating boolean argument on 
> the end, just 
> >offer a different name.
> >
> >public static byte[] decode(byte[] data);
> >public static byte[] decodeChunked(byte[] data);
> >
> >[bear in mind decodeChunked may be a bad name. I'm just copying :) ]
> >
> >Hen
> >
> >On Tue, 4 Feb 2003, Jeffrey Dever wrote:
> >
> >>There does not seem to be much choice other than overloading the 
> >>method
> >>signatures:
> >>public static byte[] decode(byte[] data);
> >>public static byte[] decode(byte[] data, boolean chunk);
> >>
> 
> 



---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message