commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Vernum <Tim.Ver...@macquarie.com>
Subject RE: Logging in applets
Date Thu, 30 Jan 2003 05:55:57 GMT
> When running the applet as an application I have no problems, 
> however when
> I try to run the applet from an HTML page any call to 
> LogFactory.getLog()
> fails with the exception:
> 
> org.apache.commons.logging.LogConfigurationException: 
> java.lang.NullPointerException

The used to be an issue when the code did not have access
to system properties, it would catch the SecurityException
and then do strange things.

I believed it was fixed (it would probably 6 months ago that I
ran into it), but it may have resurfaced, or perhaps it existed
in multiple places.


NOTICE
This e-mail and any attachments are confidential and may contain copyright material of Macquarie
Bank or third parties. If you are not the intended recipient of this email you should not
read, print, re-transmit, store or act in reliance on this e-mail or any attachments, and
should destroy all copies of them. Macquarie Bank does not guarantee the integrity of any
emails or any attached files. The views or opinions expressed are the author's own and may
not reflect the views or opinions of Macquarie Bank. 


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message