commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 16606] New: - Checking for JDK 1.4
Date Thu, 30 Jan 2003 16:48:11 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=16606>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=16606

Checking for JDK 1.4

           Summary: Checking for JDK 1.4
           Product: Commons
           Version: 1.0 Final
          Platform: All
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Logging
        AssignedTo: commons-dev@jakarta.apache.org
        ReportedBy: wen@eigner.com


In LogFactoryImpl it is checked for a JDK 1.4 being avaible by trying to load 
class java.util.logging.Logger. When using <a 
href="http://javalogging.sourceforge.net/">lumberjack</a> under JDK 1.3 it is 
therefore assumed that JDK 1.4 is available which is surely not the case. You 
will receive a java.lang.NoSuchMethodError when tying to call 
Throwable.getStackTrace() in class Jdk14Logger.
I would suggest to use another new class in JDK 1.4 to check for its existence.

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message