commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henri Yandell <bay...@generationjava.com>
Subject nullFileFilter vs getNullFileFilter
Date Fri, 27 Dec 2002 08:57:20 GMT


Sorry, lost this email, so unable to reply in-thread.

Collections.synchronisedMap, unmodifiableList etc and the various classes
of these type in Commons [lots in Collections and Lang, for example
ComparatorUtils.reversedComparator()] all seem to use the nullFileFilter
style.

I dunno if precedence counts here, but as its a unique decorator [ie) a
decorator that decorates nothing, a source], it doesn't seem to be an
immediate candidate for Bean style.

Hen

============

From: Jon Scott Stevens <jon@latchkey.com> Content-type: text/plain;

on 2002/12/25 2:16 PM, "scolebourne@apache.org" <scolebourne@apache.org>
wrote:

> -        FileFilter filter = new NullFileFilter();
> +        FileFilter filter = FileFilterUtils.nullFileFilter();

This seems like bad naming...shouldn't it be:

FileFilter filter = FileFilterUtils.getNullFileFilter();

?

-jon



--
To unsubscribe, e-mail:   <mailto:commons-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:commons-dev-help@jakarta.apache.org>


Mime
View raw message