commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 14384] - ValidatorResources.get-method not working properly
Date Thu, 14 Nov 2002 18:11:02 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=14384>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=14384

ValidatorResources.get-method not working properly





------- Additional Comments From mike.wilcox@aepona.com  2002-11-14 18:11 -------
We encountered this same bug as part of upgrading to Struts 1.1 nightly 20021105.
In short, if the browser and server locales do not match, the struts
JavascriptValidation tag fails to include the dynamic part of the javascript,
and leaves the static part rendered on-screen.

Our validation.xml has a single formset, with no specification of language,
country or variant. Server was tomcat 4.0.4. Tested with servers set to locale
en_US and  en_GB. Tested with Mozilla and IE6 set to en_US and en_GB.

The struts-validator example application showed the same symtoms on *all*
combinations of server, browser and locale.

The attached patch fixed our app. Haven't had time to check the validator app
though.

--
To unsubscribe, e-mail:   <mailto:commons-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:commons-dev-help@jakarta.apache.org>


Mime
View raw message