commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Peter Lynch" <peterly...@mindspring.com>
Subject Re: [Jelly] Ant <filterset> in jelly script issues
Date Thu, 21 Nov 2002 09:54:40 GMT
Stafan,

----- Original Message -----
From: "Stefan Bodewig" <bodewig@apache.org>
To: <commons-dev@jakarta.apache.org>
Sent: Wednesday, November 20, 2002 11:09 PM
Subject: Re: [Jelly] Ant <filterset> in jelly script issues


> On Wed, 20 Nov 2002, Peter Lynch <peterlynch@mindspring.com> wrote:
>
> > I tried with latest Ant 1.5.1 too, and that did not resolve it.
>
> Sounds as if you should file a bug report against Ant 8-)

I use standalone Ant scripts that don't exhibit this problem.

>
> > 1. <copy> filtering attribute not behaving as documented.
>
> Judging from the code it does.  All the filtering attribute does is
> adding the "global" filterset to the nested ones.

More specifically the attribute is affecting if the nested filterset with tokens
are being used correctly as documented by Ant. In that jelly script there are no
global filtersets defined. So if it was a basic Ant script, I wouldn't even need
to specify that attribute.

>
> > 3. nested filtersets inside a copy task using the refid attribute to
> > reference a global filterset does not reference the global
> > filterset.
>
> Fixed in CVS: <http://nagoya.apache.org/bugzilla/show_bug.cgi?id=9056>.
>

Actually u may not have noticed I filed that issue :). And it was a seperate
issue not described here. And that fix was included in Ant 1.5.1 which is why I
mentioned that I tried that. :)

> Could you try Ant's latest nightly (i.e. 1.6alpha) or the latest one
> from <http://cvs.apache.org/~bodewig/gump/ant1.5.2alpha/> to confirm
> that it works for you as well?
>

Since I don't see these problems in standalone Ant scripts I am doubting Ant is
the root cause. I have been wrong before. Thanks for the link.

Thanks,

Peter

> Stefan
>
> --
> To unsubscribe, e-mail:   <mailto:commons-dev-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:commons-dev-help@jakarta.apache.org>
>


--
To unsubscribe, e-mail:   <mailto:commons-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:commons-dev-help@jakarta.apache.org>


Mime
View raw message