commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 9599] - Problem accessing LogFactoryImpl from servlet
Date Thu, 26 Sep 2002 07:08:51 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=9599>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=9599

Problem accessing LogFactoryImpl from servlet





------- Additional Comments From nbrennan@touchcorp.com  2002-09-26 07:08 -------
I get the same problem if I attempt to prepend the commons-logging jar into my 
Xbootclasspath (I'm running Axis):

All I need to do to generate the error is:

Class.forName("org.apache.axis.configuration.EngineConfigurationFactoryFinder");

And I get:

          java.lang.ExceptionInInitializerError: 
org.apache.commons.logging.LogConfigurationException: 
java.lang.NullPointerException
                at org.apache.commons.logging.LogFactory.newFactory
(LogFactory.java:558)
                at org.apache.commons.logging.LogFactory.getFactory
(LogFactory.java:355)
                at org.apache.commons.logging.LogFactory.getLog
(LogFactory.java:409)
                at org.apache.axis.components.logger.LogFactory.getLog
(LogFactory.java:76)
                at 
org.apache.axis.configuration.EngineConfigurationFactoryFinder.<clinit>
(EngineConfigurationFactoryFinder.java:89)
                at java.lang.Class.forName1(Native Method)
                at java.lang.Class.forName(Class.java:142)
                at com.touchcorp.apps.kiosk.KioskServer.main
(KioskServer.java:469)

What is going on?

--
To unsubscribe, e-mail:   <mailto:commons-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:commons-dev-help@jakarta.apache.org>


Mime
View raw message