commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cost...@covalent.net
Subject Re: [discovery] minor API change...
Date Tue, 20 Aug 2002 17:03:53 GMT
+1, go for it.

I'm still experimenting with this - just found the jndi 'discovery'
for jndi.properties and jndiprovider.properties, and I'm trying to
see how it can be used for ant.tasks and taskdef.

I'm even more convinced that 'creation of instances' is less esential.

Locating resources - both classes ( drivers, tasks, interceptors, etc )
and descriptors ( properties, modeler mbean info, ant tasks, etc ) is
IMO the essential feature. 

Costin

On Tue, 20 Aug 2002, James Strachan wrote:

> The static method on ServiceDiscovery to create a new ServiceDiscovery
> implementation, based on your JDK, is right now called getServiceDiscovery()
> which looks a bit like a singleton.
> 
> How about we rename this method to something like..
> 
>     newInstance()
> 
> which would then follow the naming conventions of JAXP? Then it could be
> used as...
> 
>     ServiceDiscovery discovery = ServiceDiscovery.newInstance();
> 
> James
> -------
> http://james.weblogger.com/
> 
> __________________________________________________
> Do You Yahoo!?
> Everything you'll ever need on one web page
> from News and Sport to Email and Music Charts
> http://uk.my.yahoo.com
> 
> --
> To unsubscribe, e-mail:   <mailto:commons-dev-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:commons-dev-help@jakarta.apache.org>
> 
> 


--
To unsubscribe, e-mail:   <mailto:commons-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:commons-dev-help@jakarta.apache.org>


Mime
View raw message