commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henri Yandell <bay...@generationjava.com>
Subject Re: [VOTE] (re-vote) XxxUtils constructors
Date Thu, 22 Aug 2002 20:31:08 GMT

Hey, we've not released yet :) The only releases Lang has are:

1) A first beta. This had a private().
2) A second beta[1.1] with the public() as a favour to a single user.

I took the call that so few of our users would be affected by the change
to the beta that it wouldn't hurt any.

I am aware that my naming convention of beta1.1 is a bit confusing, I
couldn't find a good convention that fit our existing beta and didn't
sound like a big new release.

So, you're happy with the StringUtils.Bean structure as a
velocity-workable compromise?

[Which hopefully we can suggest all Commons Utils have, and possibly
supply a Collections/Math/Arrays wrapper of some kind with a similar
structure.]

Hen

On Thu, 22 Aug 2002, Geir Magnusson Jr. wrote:

> On 8/22/02 3:49 PM, "Michael A. Smith" <mas@apache.org> wrote:
>
> > On Thu, 22 Aug 2002, Geir Magnusson Jr. wrote:
> >> On 8/22/02 3:16 PM, "Henri Yandell" <bayard@generationjava.com> wrote:
> >>> What would be the Velocity change needed for this? Could someone who knows
> >>> velocity show me how velocity usage of StringUtils looks now and how it
> >>> would look with this change?
> >>>
> >>> Vel is always on my todo list it seems.
> >>
> >> What would I change in Velocity?  I would fork the string utils code and
> >> bring it back into velocity or turbine
> >
> > so, you're saying that unless StringUtils remains exactly as it was when
> > it existed in velocity or Turbine, then you'll fork it and just keep it
> > in velocity or turbine?
>
> Of course not.  You know that isn't what I am saying.
>
> >
> > The answer to Hen's question is this:
> >
> > Reference to org.apache.commons.lang.StringUtils as the name of the bean
> > class being used (wherever it might be used) would need to change to
> > org.apache.commons.lang.StringUtils.BeanWrapper.
> >
> > That's it.
>
> That would be fine in a 2.0 release.  You might not want to do that with an
> incremental release if it's already been release.
>
> I realize that's more 'listen to your customers'...
>
> >> Pain in the ass, but beats this inanity.  To avoid arguing with the purists
> >> over coding conventions
> >
> > Sorry to be a pain in the ass, but...
> >
> >>  public StringUtils() {
> >>  }
> >>
> >> [ ] +1
> >> [ ] +0
> >> [ ] -0
> >> [X] -1
> >
> > for the many reasons "privateers" have expressed before...
> >
> > But I will gladly change my vote if you can explain why the bean wrapper
> > doesn't work.  I have yet to see anyone provide any commentary about the
> > idea other than Stephen and the question from Hen.
>
> It was facetious.  We don't need a vote to make it public, as there wasnąt a
> vote needed to take it private...
>
> Commentary : sounds like a fine solution as long as you make it on a major
> release as to NOT BREAK PEOPLE ALREADY USING IT.
>
> --
> Geir Magnusson Jr.
> Research & Development, Adeptra Inc.
> geirm@adeptra.com
> +1-203-247-1713
>
>
>
> --
> To unsubscribe, e-mail:   <mailto:commons-dev-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:commons-dev-help@jakarta.apache.org>
>
>


--
To unsubscribe, e-mail:   <mailto:commons-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:commons-dev-help@jakarta.apache.org>


Mime
View raw message