commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From d...@multitask.com.au
Subject RE: [net] Porting NetComponents.jar to mainframe (USS) - readLine not working
Date Wed, 21 Aug 2002 23:40:20 GMT
If you need to ftp to/from AS/400s, how about using the FTP class that 
comes with the AS/400 Toolbox for Java.
--
dIon Gillard, Multitask Consulting
Work:      http://www.multitask.com.au
Developers: http://adslgateway.multitask.com.au/developers


"Brekke, Jeff" <Jeff.Brekke@qg.com> wrote on 22/08/2002 04:32:58 AM:

> Its a shot in the dark then to rebuild the commons-net code on your
> mainframe and see if that has the same behavior.  Sorry I can't be of 
more
> assistance.
> 
> =================================================================
> Jeffrey D. Brekke                                   Quad/Graphics
> Jeff.Brekke@qg.com                              http://www.qg.com
> 
> 
> > -----Original Message-----
> > From: Prasanna_SrinivasaRao@adp.com
> > [mailto:Prasanna_SrinivasaRao@adp.com]
> > Sent: Wednesday, August 21, 2002 12:52 PM
> > To: commons-dev@jakarta.apache.org
> > Subject: RE: [net] Porting NetComponents.jar to mainframe (USS) -
> > readLine not working
> > 
> > 
> > I am still using tje 1.3.8 Netcomponents.jar.  Also I am 
> > writing my code 
> > in mainframe (and not in AS/400)
> > 
> > Thanks
> > 
> > 
> > 
> > 
> > 
> > 
> > From: Brekke, Jeff <Jeff.Brekke@qg.com>
> > Subject: RE: [net] Porting NetComponents.jar to mainframe 
> > (USS) - readLine
> >                  () not worki
> > Date: Tue, 20 Aug 2002 21:07:35 -0500
> > Content-Type: text/plain;
> >                  charset="iso-8859-1"
> > 
> > 
> > I haven't worked on an AS/400 and am pretty green when it comes to 
> > mainframe
> > charater encoding issues. 
> > Have you built the commons-net code on the AS/400 or are you 
> > still using 
> > the
> > 1.3.8 Netcomponents jar?
> > 
> > =================================================================
> > Jeffrey D. Brekke                                   Quad/Graphics
> > Jeff.Brekke@qg.com                              http://www.qg.com
> > 
> > 
> > > -----Original Message-----
> > > From: Prasanna_SrinivasaRao@adp.com
> > > [mailto:Prasanna_SrinivasaRao@adp.com]
> > > Sent: Tuesday, August 20, 2002 2:15 PM
> > > To: commons-dev@jakarta.apache.org
> > > Subject: [net] Porting NetComponents.jar to mainframe (USS) - 
> > > readLine()
> > > not working
> > > 
> > > 
> > > Hello,
> > > 
> > > I have a requirement to transfer binary files from AS/400 to 
> > > mainframe 
> > > through FTP. 
> > > 
> > > First, I wrote a program to transfer files from AS/400 to 
> > > Windows 2000 
> > > using NetComponents and it works fine.  Next, I tired to port 
> > > my class 
> > > files and NetComponent.jar to the mainframe USS (Unix System 
> > > Services) 
> > > environment. (jdk 1.3.1). I got a 
> > > MalformedServerReplyException in the 
> > > FTP.__getReply() method while connecting.  To fix this, I 
> > changed the 
> > > _controlinput buffered reader to accept 8859_1 character 
> > > encoding and the 
> > > error went away. Now I find that   _controlInput.readLine() 
> > > is not working 
> > > in the _getReply() function during the connect method.
> > > 
> > > I am wondering whether anybody has done a port of NetComponents to 
> > > mainframe environment?  Does anyone know why readLine() is 
> > > not working. 
> > > Should I use a different line termination character (other than the 
> > > standard /r/n?)?  Is there a different character encoding 
> > to be used?
> > > 
> > > Any help would be greatly appreciated
> > > 
> > > Regards
> > > Prasanna
> > > 
> > 
> 
> --
> To unsubscribe, e-mail: 
<mailto:commons-dev-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: 
<mailto:commons-dev-help@jakarta.apache.org>
> 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message