commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Sitze <>
Subject Re: [discovery] minor API change...
Date Wed, 21 Aug 2002 14:08:59 GMT
Welcome James!


Costin, I'm only just beginning to realize the ramifications of your 
tactics, and I like them... hoping to better understand them over time.  I 
agree that what you are proposing needs to be clearly presented.  Maybe 
it's time to break out more packages?  Even rename the base package?  What 
do you think about three entry-point packages:

with 'generally useful' quick-tools and usage patterns in the base package, as is done today.

(note that I've dropped the 'y' from discovery).

Richard A. Sitze
IBM WebSphere WebServices Development

+1, go for it.

I'm still experimenting with this - just found the jndi 'discovery'
for and, and I'm trying to
see how it can be used for ant.tasks and taskdef.

I'm even more convinced that 'creation of instances' is less esential.

Locating resources - both classes ( drivers, tasks, interceptors, etc )
and descriptors ( properties, modeler mbean info, ant tasks, etc ) is
IMO the essential feature.


On Tue, 20 Aug 2002, James Strachan wrote:

> The static method on ServiceDiscovery to create a new ServiceDiscovery
> implementation, based on your JDK, is right now called 
> which looks a bit like a singleton.
> How about we rename this method to something like..
>     newInstance()
> which would then follow the naming conventions of JAXP? Then it could be
> used as...
>     ServiceDiscovery discovery = ServiceDiscovery.newInstance();
> James
> -------
> __________________________________________________
> Do You Yahoo!?
> Everything you'll ever need on one web page
> from News and Sport to Email and Music Charts
> --
> To unsubscribe, e-mail:   <>
> For additional commands, e-mail: <>

To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

View raw message