commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Sitze <rsi...@us.ibm.com>
Subject Re: [discovery] minor API change...
Date Wed, 21 Aug 2002 18:43:27 GMT
OK, I'm going to change the package name in the next day or so, unless I'm 
voted down...

root would then be "oac.discover.*".

>What about commons.discover - and rename ServiceDiscovery to 
>ResourceDiscovery. A resource can be a class name in a META-INF/services
>or anything else ( ant.tasks, etc ).

+1 to commons.discover.ResourceDiscovery.

+1 to a specialization of that for META-INF/services.

-1 to introducing ant specific code here.  We can build an extension 
mechanism that you can use in ant to meet it's needs.

>We can add a oac.discover.helpers for the stuff that you need - 
>instantiating classes, properties, even selection policy ( but the 
current 
>API is far too confusing - at least compared with the caller just doing a 

>sequence of ifs ).

We both want 'simple', its a matter of perspective.  I think it's 
confusing either way (I still don't understand how to USE all the 
information you are giving back to me).  Let's work to fix it, but don't 
throw my class locator away because it doesn't fit your specific needs. 
Can we agree to leave it alone, stop debating it, until such time as we 
your new features in place, and it's more clear to me (and possibly to 
you) what we are dealing with?

I went to the Xerces code, didn't look any different that what is already 
being done (FactoryFinder.java).  When you refer to a 'sequence of ifs', 
can you give me an explicit reference?  I'd like to see what you are 
talking about.

<ras>

*******************************************
Richard A. Sitze
IBM WebSphere WebServices Development

On Wed, 21 Aug 2002, Richard Sitze wrote:

> Welcome James!
> 
> +1
> 
> Costin, I'm only just beginning to realize the ramifications of your 
> tactics, and I like them... hoping to better understand them over time. 
I 
> agree that what you are proposing needs to be clearly presented.  Maybe 
> it's time to break out more packages?  Even rename the base package? 
What 
> do you think about three entry-point packages:
> 
> org.apache.commons.discover.resources
> org.apache.commons.discover.services
> org.apache.commons.discover.class(es)

What about commons.discover - and rename ServiceDiscovery to 
ResourceDiscovery. A resource can be a class name in a META-INF/services
or anything else ( ant.tasks, etc ).

BTW, one of the most important features I would like is the ability
to 'discover' the MANIFEST and its content :-)

We can add a oac.discover.helpers for the stuff that you need - 
instantiating classes, properties, even selection policy ( but the current 

API is far too confusing - at least compared with the caller just doing a 
sequence of ifs ).


Costin

> with 'generally useful' quick-tools and usage patterns in the base 
package 
> org.apache.commons.discover, as is done today.
> 
> (note that I've dropped the 'y' from discovery).
> 
> *******************************************
> Richard A. Sitze
> IBM WebSphere WebServices Development
> 
> 
> 
> +1, go for it.
> 
> I'm still experimenting with this - just found the jndi 'discovery'
> for jndi.properties and jndiprovider.properties, and I'm trying to
> see how it can be used for ant.tasks and taskdef.
> 
> I'm even more convinced that 'creation of instances' is less esential.
> 
> Locating resources - both classes ( drivers, tasks, interceptors, etc )
> and descriptors ( properties, modeler mbean info, ant tasks, etc ) is
> IMO the essential feature.
> 
> Costin
> 
> On Tue, 20 Aug 2002, James Strachan wrote:
> 
> > The static method on ServiceDiscovery to create a new ServiceDiscovery
> > implementation, based on your JDK, is right now called 
> getServiceDiscovery()
> > which looks a bit like a singleton.
> >
> > How about we rename this method to something like..
> >
> >     newInstance()
> >
> > which would then follow the naming conventions of JAXP? Then it could 
be
> > used as...
> >
> >     ServiceDiscovery discovery = ServiceDiscovery.newInstance();
> >
> > James
> > -------
> > http://james.weblogger.com/
> >
> > __________________________________________________
> > Do You Yahoo!?
> > Everything you'll ever need on one web page
> > from News and Sport to Email and Music Charts
> > http://uk.my.yahoo.com
> >
> > --
> > To unsubscribe, e-mail:   <
> mailto:commons-dev-unsubscribe@jakarta.apache.org>
> > For additional commands, e-mail: <
> mailto:commons-dev-help@jakarta.apache.org>
> >
> >
> 
> 
> --
> To unsubscribe, e-mail:   <
> mailto:commons-dev-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <
> mailto:commons-dev-help@jakarta.apache.org>
> 
> 
> --
> To unsubscribe, e-mail:   <
mailto:commons-dev-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <
mailto:commons-dev-help@jakarta.apache.org>
> 
> 


--
To unsubscribe, e-mail:   <
mailto:commons-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <
mailto:commons-dev-help@jakarta.apache.org>



--
To unsubscribe, e-mail:   <mailto:commons-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:commons-dev-help@jakarta.apache.org>


Mime
View raw message