commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 11228] - Rename methods that set the socket timeout to be setSocketTimeout()
Date Thu, 01 Aug 2002 14:00:52 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=11228>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=11228

Rename methods that set the socket timeout to be setSocketTimeout()

jsdever@sympatico.ca changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Summary|Please add                  |Rename methods that set the
                   |setSocketTimeout() in       |socket timeout to be
                   |HttpClient class            |setSocketTimeout()



------- Additional Comments From jsdever@sympatico.ca  2002-08-01 14:00 -------
Proposal:
1) Rename HttpConnection.setSoTimeout to be
HttpConnection.setSocketTimeout
2) Rename HttpClient.setTimeout to HttpClient.setSocketTimeout

Purpose:
To bring consistancy and clarity to the methods that set the socket
timeout.

HttpConnection.setSoTimeout was likely named that way becuase it is
basicly a pass through that calls Socket.setSoTimeout of the underlying
socket object.  This method was added in december after the alpha1
release so we should be free to change it.  Similar story for
HttpClient.setTimeout, but it was added much more recently.

Other choices would be to:
a) Change both to setSoTimeout - it is unfortunate that the underlying
socket is named this, because the name is ambiguous.  What does So mean
anyway?  So what?  Star Office? Shared Object?  I guess it means Socket,
so lets use that.
b) Change both to be setTimeout - but timeout of what?  Read the
documentation to find out it means socket.  What if we add another
timeout value for somthing else?  then we will be forced to use
setXXXTimeout and leave the inconsistant setTimeout as depricated or as
a inconsistancy.
c) do nothing - that leave the problems of a) and b) in addition to the
inconsistancy.

--
To unsubscribe, e-mail:   <mailto:commons-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:commons-dev-help@jakarta.apache.org>


Mime
View raw message