commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <>
Subject [discovery] minor API change...
Date Tue, 20 Aug 2002 15:52:04 GMT
The static method on ServiceDiscovery to create a new ServiceDiscovery
implementation, based on your JDK, is right now called getServiceDiscovery()
which looks a bit like a singleton.

How about we rename this method to something like..


which would then follow the naming conventions of JAXP? Then it could be
used as...

    ServiceDiscovery discovery = ServiceDiscovery.newInstance();


Do You Yahoo!?
Everything you'll ever need on one web page
from News and Sport to Email and Music Charts

To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

View raw message