Return-Path: Delivered-To: apmail-jakarta-commons-dev-archive@apache.org Received: (qmail 6213 invoked from network); 1 Jul 2002 23:57:47 -0000 Received: from unknown (HELO nagoya.betaversion.org) (192.18.49.131) by 209.66.108.5 with SMTP; 1 Jul 2002 23:57:47 -0000 Received: (qmail 8289 invoked by uid 97); 1 Jul 2002 23:58:01 -0000 Delivered-To: qmlist-jakarta-archive-commons-dev@jakarta.apache.org Received: (qmail 8273 invoked by uid 97); 1 Jul 2002 23:58:00 -0000 Mailing-List: contact commons-dev-help@jakarta.apache.org; run by ezmlm Precedence: bulk List-Unsubscribe: List-Subscribe: List-Help: List-Post: List-Id: "Jakarta Commons Developers List" Reply-To: "Jakarta Commons Developers List" Delivered-To: mailing list commons-dev@jakarta.apache.org Received: (qmail 8261 invoked by uid 98); 1 Jul 2002 23:58:00 -0000 X-Antivirus: nagoya (v4198 created Apr 24 2002) From: "Rand McNeely" To: "'Jakarta Commons Developers List'" Subject: RE: [lang] [patch] Numbers.containsDigits(String) Date: Mon, 1 Jul 2002 18:56:31 -0500 Message-ID: <001901c2215a$ecf46c90$6501a8c0@LT1> MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit X-Priority: 3 (Normal) X-MSMail-Priority: Normal X-Mailer: Microsoft Outlook, Build 10.0.2605 X-MIMEOLE: Produced By Microsoft MimeOLE V6.00.2600.0000 Importance: Normal In-Reply-To: <00b001c22159$7ba7ddc0$5c3929d9@oemcomputer> X-Spam-Rating: 209.66.108.5 1.6.2 0/1000/N X-Spam-Rating: 209.66.108.5 1.6.2 0/1000/N I'll be happy to write the unit test. As far as the class in general, I would... rename containsDigits to isOnlyDigits ("a9ez" contains digits) and as noted there may be some performance issues in the isNumber(String) method. Also, is there a reason we don't have a maximum(int,int,int) for completeness (as far as that goes, what about longs, etc - perhaps the method should be changed to use longs instead of ints)? Other methods that might be nice but can wait until a 1.0 release are operators for the primitive wrappers (add(Integer a,Integer b), etc). > -----Original Message----- > From: Stephen Colebourne [mailto:scolebourne@btopenworld.com] > Sent: Monday, July 01, 2002 6:46 PM > To: Jakarta Commons Developers List > Subject: Re: [lang] [patch] Numbers.containsDigits(String) > > Patch applied, thanks. > > Are there any more changes you want to make to Numbers? (If you'd like to > help a Numbers unit test would be useful!) > > Stephen > > ----- Original Message ----- > From: "Rand McNeely" > To: "'Jakarta Commons Developers List'" > Sent: Tuesday, July 02, 2002 12:06 AM > Subject: [lang] [patch] Numbers.containsDigits(String) > > > > > > > > > -----Original Message----- > > > From: Stephen Colebourne [mailto:scolebourne@btopenworld.com] > > > Sent: Monday, July 01, 2002 6:02 PM > > > To: Jakarta Commons Developers List > > > Subject: Re: [lang] is there a release on the visible horizon? > > > > > > +1, please submit a patch > > > > > > Stephen > > > > > > ----- Original Message ----- > > > From: "Rand McNeely" > > > To: "'Jakarta Commons Developers List'" > > > > > Sent: Monday, July 01, 2002 10:41 PM > > > Subject: RE: [lang] is there a release on the visible horizon? > > > > > > > > > > > > > > > > > > > > > > 6) Numbers has a lot of comments about future things. Plus > > > > > containsDigits() > > > > > > > has question marks against the null handling > > > > > > > > > > > > Question marks meaning, should containsDigit consider null to > > > > contain > > > > > > digits or not, or should it not even check. > > > > > Or should it throw an exception (and which one) > > > > > > > > > > > > > I think the current implementation for nulls is fine but there is > > one > > > > other problem, the method will return true if passed "". I can go > > ahead > > > > and take care of this. > > > > > > > > Rand > > > > > > > > > > > > > > > > > > > > -- > > > > To unsubscribe, e-mail: > > > > > > > For additional commands, e-mail: > > > > > > > > > > > > > > > > -- > > > To unsubscribe, e-mail: > > unsubscribe@jakarta.apache.org> > > > For additional commands, e-mail: > > help@jakarta.apache.org> > > > > > ------------------------------------------------------------------------ -- > -- > ---- > > > > -- > > To unsubscribe, e-mail: > > > For additional commands, e-mail: > > > > -- > To unsubscribe, e-mail: unsubscribe@jakarta.apache.org> > For additional commands, e-mail: help@jakarta.apache.org> -- To unsubscribe, e-mail: For additional commands, e-mail: