commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henri Yandell <bay...@generationjava.com>
Subject RE: [lang] JDK 1.0/1.1
Date Thu, 11 Jul 2002 18:41:54 GMT

> I doubt there are many people actually using JDK 1.0, so we can
> probably drop support for that.

Agreed. I suspect that with Lang's area that any 1.1 version will work on
1.0, but would need to test compiling. It would be worth verifying if it
compiles there, but as I think JUnit is 1.2 we can't promise that unit
tests run. If 1.0 doesn't compile, then not important.

> As to JDK 1.1.x, the picture is a bit fuzzy.  I know I am not using
> it, but I don't know who might be.  M$ JDK is way behind the times,
> and FreeBSD has support for JDK 1.2+ I believe.  There comes a time
> when backwards compatibility becomes more of a problem than what it
> hopes to solve.

There's the MS crap, latest thing being the MS JVM coming back at 1.1.4,
so that's of interest, but there's also the whole J2ME world where half of
the semi-J2ME compliant systems are actually PersonalJavas pretty much.
PJ was just java 1.1 with some bits hacked on. J2ME is the same I think.
Equally, J2ME does get the collections in java.util I believe, so that
could help.

Equally, no exceptions down there, so we'd have to do a conditional build
[only just occured to me].

What I basically realised, which kicked this off, is that Lang is not a
server component, but a component for use in any Java. It's hopefully
going to get a lot of server side use, but no reason why the embedded
world wouldn't see fit to use it unless space was an absolute premium.

Hen


--
To unsubscribe, e-mail:   <mailto:commons-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:commons-dev-help@jakarta.apache.org>


Mime
View raw message